rr.level3.net on autopilot?

I was doing some IRR clean-up and after a few successful updates, I'm no longer able to alter or delete our objects in rr.level3.com.

Emails to rpsl@level3.com result in no action and no response. I've tried reaching out to the Level3 (Centurylink) NOC via email and phone, and can't seem to find anyone who knows what rr.level3.com is, much less knows who to talk to about troubleshooting. Anyone know who (if anyone) keeps the wheels spinning on the Level3 IRR?

The other day I tried to clean up some old entries from the 2000's and Genuity
entries that became part of it. This was a failure, the NOC knew nothing
about it, and worse didn't get my black rocket jokes. No one working there
knew what Genuity was.

I gave up.

Shoot an email to ipadmin@centurylink.com and we'll give you a hand. If you are an active customer with valid circuit ID getting help from the NOC on this should be a solution they know how to provide, if you have reached the correct center. Folks that are not or have left behind old entries needing removed without a current relationship reach out to the ipadmin team for help.

AS1, baby!!

For following up, their IPadmin team (person) did reach out and resolve this
asap for us.


I was going to post this morning that things are all sorted out. Centurylink's IP Admin reached out and worked with me to figure out the issue, which appears to have been that someone a few layers up from rpsl@level3.com cranked their spam filtering up to 11, resulting in all externally originated email getting eaten somewhere in their systems.

Before posting, I ran one more test, and found that there's still something not quite right. We worked together again today, trying to figure it out, but ended up giving up for now.

Mail from my personal system and from a Linux server at work both get delivered and processed properly. Mail from my work email Outlook/Microsoft/Mimecast gets delivered to Level3.com, but the IRRD system fails to find any objects in the body and responds that no object was found. Yes, it's being sent as plain text (Content-Type: text/plain; charset=UTF-8). Sending the same message from work to my personal address, then taking that, changing To: and playing the entire thing (all the headers + body) through sendmail -oi -t on a Linux server at work, it gets delivered and properly processed.

So, anyone else who's had trouble the past 2 weeks getting anything processed by rpsl@level3.com, you should be able to at least get your messages delivered now. I'm curious if any other Office365/Outlook.com users have issues with rpsl@level3.com not finding any objects in your updates. If you're having that problem, resend your message via another mail system and see if that works for you too.