Recovery mode on Juniper M7i

Hello everyone!

Greetings of the day.

I am kind of (badly) stuck with multiple routers and not able to recover
the root password. It's Juniper M7i. I have followed the Juniper support
page as given here -
strange enough that it worked with one of routers I have but failed on
rest all.

I am getting stuck on Step #12. As I give "boot -s" to get into single user
mode of BSD, system next asks me for root password and hence I am out of
luck to get into "recovery mode". I tried pressing enter on that prompt as
well but no luck. I am connecting to router via console and do have
physical access to router(s).

Was wondering if someone has seen similar issues and could guide on what I
am doing wrong? Most of other help pages I have seen on net have same exact
steps as given on that page.


what's your junos version?

Maybe you're not doing anything wrong and someone tweaked the routers and
marked the console as insecure, a previous owner maybe?


Can you paste in the output after 'boot -s' , I came across several issues
while recovering Root Password, But never faced this :slight_smile:

Hi sure

Please find screenshot...

@Mehmet - I checked that in daytime and didn't found anything specific
about that version. Sorry don't have it handy with me right now but will
check exact version again in morning and will update you.

Direct access to the bootstrap loader should bypass any access restrictions configured on the box. However, it sounds like the device is not dropping into single-user mode.

I would suggest removing and wiping the CF card. Then boot from alternative media (USB) and snapshot on to the blank card.


I was able to access routers by flashing 1st router's image on remaining.

Issue with other three as to best extent I can guess was that someone
enabled root password in single user mode and so there was no way around to
get to recovery console.

Thanks everyone for useful replies.