Multicast Ethernet frames not bridging between wired and wireless, Netgear CPE

I've a Netgear 7550 B90 provided by Frontier. (Yes, it's my only choice
other than VSAT. Rural US. Yes, I am already looking into getting my own
CPE, but humor me.)

Since Frontier doesn't support IPv6, I've linux box on the LAN building an
AYIYA tunnel, and doing the usual router thing on the wired Ethernet.
Everything on the wired side works splendid.

Wireless clients didn't seem to want to play. Further digging indicates
that RA and NS don't cross the bridge from wired to wireless. Manually
assigning IPv6 address and nailing NDP entries allows ICMPv6 echo request
to work.

Has anyone seen this class of device drop multicast between the wireless
radio and the wired ethernet switch?

Or am I brain dead this morning and missing something obvious? Heck, I
even tried disabling WPA2 thinking it was some wonky encryption thing.


Are you using the Netgear device for wireless, or is there a wireless
adapter/card/whatever in your linux box?

If you have linux running on the wireless thingy, u might find the
proxy_ndp options useful (/proc/sys/net/ipv6/...)

I have a Netgear WG102 running as bridge and it worked without any
further tweaking. But, I transport the data via tagged VLANs up to the
Netgear who extracts them for each SSID individually.

I've seen some Linux boxes in bridge mode do strange things with wireless and ipv6. Using wds mode resolved it. Is the wireless in wds mode?

Netgear was the wireless/wired/ADSL from the provider. Workaround was to
make that an ADSL-Ethernet bridge and run PPPoE on another, unbroken,
wireless router (WRT54G OpenWrt).