COnfiguration Suggestion - Etherchannel

Hey Everyone,

I am building out a customer that needs more than 1000Mbps of sustained
bandwidth. Because of the customer equipment, etherchannel was suggested
as the means to do this (it is compatible with this customers equipment).

I am running a 6509 with Dual SUP720's in IOS mode only (no cat software).

It was pointed out that there are really two different ways to configure
the switch - I guess my question is which is the best (lowest overhead,
etc)? Hopefully someone out there has been down this road before.

TIA

Two methods:

!
interface Port-channel2
no ip address
switchport
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet7/1
no ip address
switchport
switchport access vlan 10
switchport mode access
channel-group 2 mode on
!
interface GigabitEthernet8/1
no ip address
switchport
switchport access vlan 10
switchport mode access
channel-group 2 mode on
!
interface Vlan10
description Customer_Name
ip address 192.168.0.1 255.255.0.0
no ip redirects
no ip unreachables
!

And then there is this way:

!
interface Port-channel2
description Customer_Name
ip address 192.168.0.1 255.255.0.0
no ip redirects
no ip unreachables
!
interface GigabitEthernet7/1
description Customer_Name EtherChannel Interface #1
no ip address
channel-group 2 mode on
!
interface GigabitEthernet8/1
description Customer_Name EtherChannel Interface #2
no ip address
channel-group 2 mode on
!

Do you need VLAN support or just a routed interface ?

Robert,

Just a routed interface.

I would use method #2 above.. L3 FEC produces better balancing
results as it is flow based, rather than mac-based. I'm not 100%
certain that using the SVI interface would not produce a proper
balance, but I doubt it. Using method one I would expect only one
of the links to be used.

Use method 2 especially if you mean this to be a L3 handoff to the
customer.

Mike Sawicki (fifi@HAX.ORG)

Richard J. Sears wrote:

I am building out a customer that needs more than 1000Mbps of sustained
bandwidth. Because of the customer equipment, etherchannel was suggested
as the means to do this (it is compatible with this customers equipment).

I am running a 6509 with Dual SUP720's in IOS mode only (no cat software).

It was pointed out that there are really two different ways to configure
the switch - I guess my question is which is the best (lowest overhead,
etc)? Hopefully someone out there has been down this road before.

I don't think there is really any performance difference in the two you've suggested. In one you're required to create a layer2 VLAN with a Layer3 hop on the VLAN itnerface, in the other you're just setting up a Layer3 only interface to the customer. (no vlans required) If you don't need a Layer2 connection to the customers network, then go with the Layer3 only option.

Mike Sawicki wrote:

I would use method #2 above.. L3 FEC produces better balancing
results as it is flow based, rather than mac-based. I'm not 100%
certain that using the SVI interface would not produce a proper
balance, but I doubt it. Using method one I would expect only one
of the links to be used.

Use method 2 especially if you mean this to be a L3 handoff to the
customer.

What Mike states is correct about the layer2 vs layer3 load balancing:

http://www.cisco.com/en/US/customer/products/hw/switches/ps700/products_configuration_guide_chapter09186a008007f648.html

Understanding Load Balancing
EtherChannel balances traffic load across the links in a channel by reducing part of the binary pattern formed from the addresses in the frame to a numerical value that selects one of the links in the channel.

EtherChannel load balancing can use either MAC addresses or IP addresses and either source or destination or both source and destination addresses. The selected mode applies to all EtherChannels configured on the switch.

Use the option that provides the greatest variety in your configuration. For example, if the traffic on a channel is going only to a single MAC address, using the destination MAC address always chooses the same link in the channel; using source addresses or IP addresses may result in better load balancing.

Robert Blayzor <rblayzor@inoc.net> uttered the following thing:

>of the links to be used.
>
>Use method 2 especially if you mean this to be a L3 handoff to the
>customer.

What Mike states is correct about the layer2 vs layer3 load balancing:

Cisco

Understanding Load Balancing
EtherChannel balances traffic load across the links in a channel by

On a related note - is it possible to get a 650x switch to perform flow
based etherchannel load balancing, WITHOUT the switch actually routing
(ie performing purely swithcing functions)??

Ben Buxton wrote:

On a related note - is it possible to get a 650x switch to perform flow
based etherchannel load balancing, WITHOUT the switch actually routing
(ie performing purely swithcing functions)??

I believe you then have to play around with the frame distribution settings in the Cat to maybe get what you're after. I only see the options in CatOS, I didn't dig too deep to find in in the Native IOS command set.

From Cisco:

When configurable, EtherChannel frame distribution can use MAC addresses, IP addresses, and Layer 4 port numbers. You can specify either source or destination address or both source and destination addresses and Layer 4 port numbers. The mode you select applies to all EtherChannels configured on the switch. Use the option that provides the greatest variety in your configuration. For example, if the traffic on a channel is going to a single MAC address only, using source addresses or IP addresses or Layer 4 port numbers as the basis for frame distribution may provide better frame distribution than selecting MAC addresses as the basis.

I think that's about as good as it gets...