Strangeness in the global routing tree?

This morning, I was awaken by one of my NOC guys because a customer of
mine BGP was flapping. The scoop:

A cisco 7206, with three full views, 128 megs of Ram, 11.1.19(CA). I have
four customers off of this router on an ethernet who are running BGP to
me. I am sending them full views. Two are ciscos, one is a Bay, and the
other is a PC running GATED.

This morning, around 8 AM, the Gated box started going crazy. The 7206
would start the BGP session, it would feed the Gated box almost all the
routes, then the session would unexpectedly just die, on the cisco side it
went 'idle', on the Gated side, he got an 'unexpected EOF'.

So, I thought maybe he was running out of memory; so, I filtered things so
he would only get about 40 routes. It worked fine. I started adding stuff
(via filter-list and as-path access-lists), and worked all they way up to
50,000 routes, and it is still ok. But, if I take the filter off and feed
him full routes, it breaks again. Wierd.

Remember, on the same router, on the same BGP process, I am peering with
two ciscos and a Bay with no problems.

Any thoughts? Anyone else see the same strange behavior from a GateD
box this morning?

Maybe it's y2k related, or has to do with el nino... :slight_smile:

-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
                  Atheism is a non-prophet organization.
       I route, therefore I am.
       Alex Rubenstein,, KC2BUO, ISP/C Charter Member
               Father of the Network and Head Bottle-Washer
     Net Access Corporation, 9 Mt. Pleasant Tpk., Denville, NJ 07834
Don't choose a spineless ISP! We have more backbone!
-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --

What OS and gated version? I've been feeding "full routes" to a Linux box
running gated 3.5.8, but in my case that only adds up to about 49829
routes on the Linux box.