Quanta LB4M

Has anyone gotten a "non-factory" firmware to go onto these guys? There are a couple threads on Google that are inconclusive. There are rumors that it's the same as a Dell something or an HP something else, but no one has outright said, "I loaded a Dell XXXX firmware onto it and solved all of the random ass bugs."

If I didn't already have a couple of stacked Extreme x400s, I'd consider these at home, but they're somewhat buggy.

Quanta told me to contact whomever I bought it from... but I don't think the random guy on eBay is going to have much of anything useful to say.

Oh FSM, those things. Urgh.

They are like the EIF24G series and 10GCF from Foundry - OEM devices that vendors can just rebrand with their own logos and sell.

I've tried swapping the firmware on the EIF24G-As and the Dell equivalent, and its been a miss every time. Got several of them at one point with 'defective ports' that magically got fixed with a firmware upgrade.

Even with the firmware upgrades, STP was a hot mess on them causing odd blocking situations.

Your better off going with something like the new Ubiquiti EdgeSwitch Lite.

*nods* I'm surprised that I missed that announcement until this morning. Given the love\hate I have with UBNT, I may end up getting them... and then hating myself for it.

Those in the WISP business will understand. For those not in the WISP business, case of vendor doesn't listen on a regular enough basis. I have some of their products and love them to death. The others I beat over their heads with the issues. Wait, that gave me an idea for the next time I see them...

Last February at the spring WISPA show, I gave several vendors an SFP. I've been requesting SFP cage on many products for many years (sometimes multiple generations of product) only to largely be ignored. I concluded that their engineering teams must not know what SFPs are and thus gave one to each of them to take back to their engineering teams so they could figure out how to make it happen.

I managed to brick one of these by loading the wrong firmware, or doing it at the wrong layer.

I have gotten a few more and these are great switches for home or environment where you have a spare on hand. You can usually get them for around $100 on eBay.

The firmware is *really* not designed for anything fancy but I’ve been able to drop in a variety of optics and have it work without issues in the 10G ports.

Check the flash on them as there is a primary/secondary flash once you’re past the boot image. (Don’t try to flash it from that level, that’s how I killed it at least).

I tossed a few different firmware versions I extracted here, as well as the flash0/flash1 images and the doc i found for it.


- Jared

I noticed that one I have already has the firmware. Upon switching to it, I noticed that I gained SSH, but lost HTTP. Has anyone else seen that?

Apparently the newer version of VxWorks doesn't have HTTP management.

Thank you Jared. Still helpful almost 3 years later.

Happy it’s helping!

- Jared