EoMPLS vlan rewrite between brands; possibly new bug in Cisco IOS 15

Hi, I am using a couple of AToM/EoMPLS tunnels in order to carry customer voice and data traffic across our IP/MPLS core, and it is currently working just fine. The first side consists of a Cisco 7600 router (rsp) and the other one is an HP A5500-HI routing switch with full LER/E-LSR capability. At the HP site, the tunnels are facing the access ports towards our premium end-customers; and on the Cisco PE I terminate the tunnels on one of the 2x10GE portchannel backbone links. There is vlan X on the HP side and vlan Y on the Cisco side - vlan rewrite is working perfectly - as long as I use IOS 12.

After upgrading the Cisco router software to IOS 15 the tunnels won't come up. sh mpls l2 vc Y d says:
Last error: Imposition VLAN rewrite capability mismatch with peer

I use almost exactly the same Cisco configuration before and after the upgrade (only minor changes and nothing related to this) and I havn't touched the HP. Apparently they don't talk the same L2PW language. I wonder though, why now? We use service instances on the HP switchport as endpoint, we initiate the targetted LDP session in addition to the pseudowire handshake from a sub interface MPLS crossconnect. There is no MTU mismatch; not here - not anywhere.

Anyone heard of this issue or experienced it?

Best regards,

Jonas Björk
SNE, Europe/Sweden (hope you guys will help me anyway:)

Been forever since i looked at cisco, however sounds like vc type mismatch. They used to have it as a platform capability, perhaps SW upgrade changed the default.

to my memory "show mpls l2 transport" should provide enough details.

Hope this helps


Dear Mr. Jeff,

Thank you for your reply. Below is the complete output in question (l2 is short for l2transport).
You are mentioning platform capabilities and that the default might have changed. How do I alter this?

pe#sh mpls l2 vc 42 d
Local interface: Po190.42 up, line protocol up, Eth VLAN 42 up
  Destination address: X.X.1.89, VC ID: 42, VC status: down
    Last error: Imposition VLAN rewrite capability mismatch with peer
    Output interface: none, imposed label stack {}
    Preferred path: not configured
    Default path: no route
    No adjacency
  Create time: 00:00:59, last status change time: 00:31:40
    Last label FSM state change time: 00:00:18
    Last peer autosense occurred at: 00:00:18
  Signaling protocol: LDP, peer X.X.1.89:0 up
    Targeted Hello: X.X.0.2(LDP Id) -> X.X.1.89, LDP is UP
    Graceful restart: not configured and not enabled
    Non stop routing: not configured and not enabled
    Status TLV support (local/remote) : enabled/not supported
      LDP route watch : enabled
      Label/status state machine : remote invalid, LruRnd
      Last local dataplane status rcvd: No fault
      Last BFD dataplane status rcvd: Not sent
      Last BFD peer monitor status rcvd: No fault
      Last local AC circuit status rcvd: No fault
      Last local AC circuit status sent: DOWN PW(rx/tx faults)
      Last local PW i/f circ status rcvd: No fault
      Last local LDP TLV status sent: No fault
      Last remote LDP TLV status rcvd: Not sent
      Last remote LDP ADJ status rcvd: No fault
    MPLS VC labels: local 242, remote 1199
    Group ID: local 0, remote 0
    MTU: local 9216, remote 9216
    Remote interface description:
    Remote VLAN id: 42
  Sequencing: receive disabled, send disabled
  Control Word: Off (configured: autosense)
  SSO Descriptor: X.X.1.89/42, local label: 242
    SSM segment/switch IDs: 0/0 (used), PWID: 142
  VC statistics:
    transit packet totals: receive 0, send 0
    transit byte totals: receive 0, send 0
    transit packet drops: receive 0, seq error 0, send 0

Anyone else: feel free to join in. Maybe we have any L2VC/PW ninjas watching.

Best regards,
Jonas Bjork


As expected - the problem is related to vc type negotiation.

You have hit CSCuq28998 :slight_smile:
talk to your cisco rep

- configure VC type 5 between the routers (configured on HP side)
- configuring no-control-word

The bug has been reported in 15.2(4)S4a, perhaps there’s an image with the problem fixed.


Thank you Jeff, I'll check it out on the HP side since Cisco seems to not care:

Known Fixed Releases: (0)
No release planned to fix this bug

Best regards,
Jonas Bjork

Hi Jonas,

In that output you have "Remote VLAN id: 42" -What is the local VLAN
ID on your Cisco PE? Do you need to VLAN rewrite here?

Since you using different VLANs at each end, can you build the
pseudowire at a point in the network stack where the VLAN tag has been
popped off already and transport the frames untagged, so they will be
pushed on again at the other end? (Is this is a VC type 4 pseudowire,
check with "show mpls l2transport binding 42", if so, a dummy VLAN
should be pushed on and popped off transparently if all hardware in
use supports it).

I don't know HP but with the Cisco 7600 for example, if it's VLAN 50
then you could add "interface vlan 50; xconnecy X.X.1.89 42 encaps
mpls", if your hardware supports that. Or use mux-uni; "int gix/x.y;
encaps dot1q y; xconnecy X.X.1.89 42 encaps mpls". Then add vice versa
on the HP kit.

What IOS have you tried to upgrade to, 15.2(4)S4a? If this is a VC
type 4 pseudowire and either the HP or Cisco isn't supporting
inserting a dummy VLAN tag, why is this a VC type 4 pseudowire? The
VLAN re-write I guess. Certainly in IOS 15.3 (so probably also in 15.2
but I'm not 100% certain of that) Cisco IOS should be defaulting to VC
type 5 unless the other end negotiates down to VC type 4. VC type 5 in
IOS supports transporting of untagged, tagged and double tagged
frames, I don't think there is any functionality in VC type 5 that
wasn't in older type 4's so I'd try and work out why your devices are
negotiating type 4 and maybe try to fix that, or as above, transport


Dear Mr. Bensley,

The platform is Cisco 7600 on side A and HP A5500-HI on side B. I am currently running IOS v12.2-33.SRE5 and I'm trying to upgrade to v15.3-3.S6.
In the current version the VC type is Eth VLAN and I have tried all different options on the HP side with no success. On the Cisco side I don't know if there is anything I can do - the negotiation seems to take place without any possible user interference.

It's true that I can terminate the tunnel elsewhere and switch the traffic using layer 2 but I don't want to have any "ugly" solutions in the network. Everything works fine even though I rewrite the vlan id (and that is essential for my solution) at the moment and it bothers me that an IOS upgrade triggers this bug. The bug is submitted (against Juniper) as previously mentioned in this thread but Cisco won't do anything about it.

Best regards,

Jonas Bjork
Network Nerd


If the problem is in VC type 4 signalling, then switch to Ethernet interworking or VC type 5. It will work in your case, and VLAN rewrite operation will be done at the AC points.

I don't know if you already has this configured or not, but you have to use psudowire-class templates with the "interworking ethernet" underneath.

Mohamed Kamal