[c-nsp] L2VPN with IP address

The multihop BGP solution might be the best one with least overhead;

however you should be able to use a GRE tunnel if you still want to do this:

interface Tunnel1
ip address 10.10.10.1 255.255.255.252
tunnel source FastEthernet0/0
tunnel destination small.router.ip

interface Tunnel1
ip address 10.10.10.2 255.255.255.252
tunnel source FastEthernet0/0
tunnel destination big.router.ip

-k

Just pay attention to MTU with GRE tunnel and packet fragmentation.